Analytics daily refresh failed impacting data exports.

Incident Report for Recharge

Resolved

The issue with the Merchant Analytics data refresh is fixed. All data is now refreshed.
Posted Apr 07, 2026 - 08:02 PDT

Identified

Merchant Analytics daily data refresh is delayed; the issue has been identified, the fix is being implemented, and we expect all data to be refreshed at 10:00 AM ET.
Posted Apr 07, 2026 - 03:59 PDT
This incident affected: Recharge Platform (Recharge Analytics).