Frictionless Payments Customers Unable To Update Payment Methods

Incident Report for Recharge

Resolved

We have resolved this issue and Frictionless Payments has been re-enabled on all stores.
Posted Mar 19, 2025 - 11:55 PDT

Identified

Our team has identified the issue with our service partners and are determining next steps.

As a workaround in the interim, customers billed through Shopify will be redirected to Shopify to update their details. Customers billed through Recharge will be able to update their payment method using a form in the Customer Portal.

We will continue to investigate.
Posted Mar 19, 2025 - 10:51 PDT

Investigating

We are aware of an issue with stores using the Frictionless Payments function in the Customer Portal are experiencing issues attempting to add or update customer payment methods. Our team is investigating.
Posted Mar 19, 2025 - 10:21 PDT