Merchant Admin Outage

Incident Report for Recharge

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 14:53 PDT

Monitoring

The issue has been resolved and all stores should now see recovery. Our team will continue to monitor services.
Posted Sep 10, 2025 - 14:25 PDT

Identified

The issue has been identified and stores should be seeing recovery. We will continue to provide updates.
Posted Sep 10, 2025 - 14:13 PDT

Investigating

We are investigating an issue affecting the Merchant Portal and Customer Portal. We will continue to provide updates as we review.
Posted Sep 10, 2025 - 14:00 PDT
This incident affected: Recharge Platform (Recharge Customer Portal, Recharge Merchant Portal).