Stale data for 9/17/25 on some analytics dashboards

Incident Report for Recharge

Resolved

This issue is now resolved and data for 9/17/25 is now displaying as expected on the analytics dashboards.
Posted Sep 18, 2025 - 12:37 PDT

Identified

We have identified the issue and are working on a fix.
Posted Sep 18, 2025 - 07:52 PDT

Investigating

Our team has identified that some analytics dashboards are reflecting stale data for 9/17/25. We are working to identify the issue and update the data.
Posted Sep 18, 2025 - 07:49 PDT
This incident affected: Recharge Platform (Recharge Analytics).