Delayed analytics data

Incident Report for Recharge

Resolved

This has been resolved and data for 6/28/26 is displaying as expected.
Posted Jun 29, 2026 - 11:40 PDT

Identified

We have identified the source of the delay and a resolution is in progress.
Posted Jun 29, 2026 - 07:32 PDT

Investigating

Analytics data for 6/28/26 is delayed on some dashboards and reports. Our team is currently working to ensure this is updated.
Posted Jun 29, 2026 - 07:14 PDT
This incident affected: Recharge Platform (Recharge Analytics).