Cancellation Prevention Insights Dashboard Not Loading

Incident Report for Recharge

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 10:00 PDT

Monitoring

The issue is resolved and the dashboard is loading as expected.
Posted Apr 24, 2025 - 08:15 PDT

Identified

We have identified the issue preventing this dashboard from loading and are currently working on a fix.
Posted Apr 24, 2025 - 07:05 PDT
This incident affected: Recharge Analytics.