Stale Analytics Data

Incident Report for Recharge

Resolved

This issue is now resolved and data for 9/24/25 is displayed on the home and analytics pages as expected.
Posted Sep 25, 2025 - 08:50 PDT

Update

This issue is now resolved and data for 9/24/25 is displayed on the home and analytics pages as expected.
Posted Sep 25, 2025 - 08:50 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 25, 2025 - 05:07 PDT
This incident affected: Recharge Platform (Recharge Analytics).