Intermittent 404 errors when accessing the Recharge merchant portal

Incident Report for Recharge

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 17:11 PDT

Investigating

Some merchants are receiving 404 errors when attempting to access the Recharge merchant portal. We are currently investigating the issue.
Posted Jun 25, 2025 - 16:25 PDT
This incident affected: Recharge Merchant Portal.