Updating payment methods in Affinity customer portal is currently down for a small number of stores
Incident Report for Recharge
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 13:57 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 18, 2024 - 12:04 PDT
This incident affected: Recharge Customer Portal.