Upcoming Charge Notification Delay

Incident Report for Recharge

Resolved

This has been resolved.
Posted Aug 07, 2026 - 18:20 PDT

Update

Our team has determined that impacted stores are primarily those that rely on the charge/upcoming webhook for third party notifications and custom functions. We will be reaching out directly to these stores.
Posted Aug 07, 2026 - 10:57 PDT

Monitoring

Our team has resolved the root cause of this issue. We are now reviewing potential impact.
Posted Aug 07, 2026 - 09:05 PDT

Identified

We are investigating an issue that caused delays with Upcoming Charge Notifications. Our team has identified the issue and continue to work on remediation.
Posted Aug 07, 2026 - 07:07 PDT
This incident affected: Recharge Platform (Recharge Webhooks).