Required Maintenance: January 25

Incident Report for Recharge

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 06:08 PST

Update

We are still seeing recovery, and analytics backfilling remains in progress. Analytics from January 26, 2025 onward, may be unavailable at this time. Our team is actively working to resolve fully.
Posted Jan 29, 2025 - 08:37 PST

Update

We continue to see recovery across all systems, some stores may see a delay in the data from 1/26/25 populating in the Analytics dashboards.
Posted Jan 27, 2025 - 05:47 PST

Update

We continue to see recovery across all systems and continue to monitor as any backlogs process.
Posted Jan 26, 2025 - 15:24 PST

Monitoring

We are seeing recovery across all systems and continue to monitor as any backlogs process.
Posted Jan 26, 2025 - 12:59 PST

Update

We are receiving reports of some users experiencing degraded performance and a delay in order processing. We are continuing to work to resolve this issue.
Posted Jan 26, 2025 - 10:13 PST

Update

We are receiving reports of some users experiencing degraded performance and a delay in order processing. We are currently investigating this issue.
Posted Jan 26, 2025 - 05:49 PST

Investigating

We are currently investigating this issue.
Posted Jan 26, 2025 - 03:12 PST

Monitoring

Our Engineers have completed the upgrade work and are monitoring.
Posted Jan 26, 2025 - 02:23 PST

Investigating

Maintenance is ongoing.
Posted Jan 25, 2025 - 23:13 PST
This incident affected: Recharge Analytics, Recharge API, Recharge Charge Processing, Recharge Customer Portal, Recharge Developer documentation, Recharge Checkout, Recharge Merchant Portal, Recharge Payments website, RechargeSMS, Recharge Store Front, and Recharge Webhooks.