API degradation across several services

Incident Report for Recharge

Resolved

This has been resolved.
Posted Dec 16, 2025 - 15:44 PST

Monitoring

A fix has been implemented and we are seeing recovery.
Posted Dec 16, 2025 - 15:05 PST

Update

We are still investigating reports of API degradation affecting several services, including product search within the Recharge admin and customer portal access issues for some users.
Posted Dec 16, 2025 - 14:50 PST

Investigating

We are currently receiving reports of API degradation affecting several services, including product search within the Recharge admin for some users. Our team is actively investigating the issue.
Posted Dec 16, 2025 - 14:11 PST
This incident affected: Recharge Platform (Recharge API, Recharge Customer Portal, Recharge Merchant Portal).