Getting timeouts (504 status) from the merchant and customer portal UI

Incident Report for Recharge

Resolved

This incident has been resolved since 11:10 AM ET when our provider rolled back an upgrade. We continued monitoring and have observed full recovery.
Posted Aug 18, 2025 - 13:51 PDT

Monitoring

A fix has been implemented and we are continuing to monitor the results.
Posted Aug 18, 2025 - 09:28 PDT

Investigating

We are currently investigating this issue.
Posted Aug 18, 2025 - 01:49 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2025 - 01:30 PDT

Identified

Issues with the merchant portal UI
Posted Aug 18, 2025 - 01:10 PDT
This incident affected: Recharge Platform (Recharge Customer Portal, Recharge Merchant Portal).