Platform Service Disruption

Incident Report for Recharge

Resolved

All Recharge services are operational. We are continuing to monitor ongoing third-party service provider issues.
Posted Jun 12, 2025 - 13:39 PDT

Monitoring

At this time, all Recharge services have returned to normal. We are continuing to monitor the ongoing Google Cloud service disruption to ensure no further impact.
Posted Jun 12, 2025 - 12:31 PDT

Investigating

We are currently experiencing issues related to an ongoing Google Cloud outage. At this time merchant analytics dashboards are unavailable, however we are continuing to investigate the scope of impact.
Posted Jun 12, 2025 - 11:29 PDT
This incident affected: Recharge Analytics.