Delayed Shopify Checkout Contract Creation

Incident Report for Recharge

Resolved

The issue is now resolved. We have successfully imported all Customer and Subscription information that was delayed.
Posted Mar 28, 2025 - 13:12 PDT

Monitoring

Our team has deployed a fix for the root cause. We are now monitoring the import of contracts to ensure that all impacted stores are corrected.
Posted Mar 28, 2025 - 12:39 PDT

Identified

Our team has located the cause of the issue and are working to correct it prior to importing missing contracts.
Posted Mar 28, 2025 - 10:19 PDT

Update

We are continuing to investigate this issue.
Posted Mar 28, 2025 - 10:02 PDT

Investigating

We're aware of a small subsection of stores experiencing delays on new Shopify checkouts creating customer records in Recharge. Our team is investigating the root cause of the issue.
Posted Mar 28, 2025 - 09:04 PDT