Customer Timeline Not Loading

Incident Report for Recharge

Resolved

This incident has been resolved and all customer timelines are loading now.
Posted Jun 30, 2025 - 13:10 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 30, 2025 - 12:57 PDT

Investigating

We are currently investigating an issue where customer timelines are not loading in some stores.
Posted Jun 30, 2025 - 12:50 PDT
This incident affected: Recharge Merchant Portal.