Degraded Admin Accessibility

Incident Report for Recharge

Resolved

This incident has been resolved.
Posted Dec 17, 2025 - 10:24 PST

Monitoring

A fix has been implemented, and we are seeing full recovery.
Posted Dec 17, 2025 - 10:06 PST

Update

We are starting to see some recovery and are continuing to work to get fully resolved.
Posted Dec 17, 2025 - 09:36 PST

Update

We are starting to see resolution and are continuing to investigate.
Posted Dec 17, 2025 - 09:35 PST

Investigating

We are currently seeing degraded admin accessibility in the merchant portal and are investigating.
Posted Dec 17, 2025 - 09:21 PST
This incident affected: Recharge Platform (Recharge Merchant Portal).