Email Domain Authentication Issues

Incident Report for Recharge

Resolved

We are observing full recovery and will continue monitoring.
Posted Nov 04, 2025 - 14:07 PST

Identified

We are aware of an issue impacting Sendgrid use in some stores. Our team is investigating.
Posted Nov 04, 2025 - 13:25 PST
This incident affected: Recharge Platform (Recharge Merchant Portal).