API Latency Issues

Incident Report for Recharge

Resolved

This incident has been resolved.
Posted May 01, 2025 - 15:51 PDT

Update

We experienced API latency this morning resulting in slow customer portal load times as well as some charge errors on limited stores. A fix has been released, we are continuing to see recovery and all related charge errors are being retried.
Posted May 01, 2025 - 10:57 PDT

Monitoring

A fix has been implemented and we are continuing to monitor the results.
Posted May 01, 2025 - 07:17 PDT

Identified

We are seeing slow loading times on some Customer Portals. We have identified the issue and are working on a fix.
Posted May 01, 2025 - 05:34 PDT
This incident affected: Recharge Customer Portal.