Customer Portal Inaccessible
Incident Report for Recharge
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 12:39 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 13, 2024 - 12:35 PST
Investigating
We are investigating and have identified an issue with 403 errors when accessing the customer portal
Posted Nov 13, 2024 - 12:34 PST
This incident affected: Recharge Customer Portal.