Issue with charge processing

Incident Report for Recharge

Resolved

The root cause of this incident has been resolved. Those impacted will receive further communication.
Posted Nov 12, 2025 - 16:36 PST

Update

At this time only a limited subset of stores are impacted and our team is working to address lingering issues. Store updates will continue to be made throughout the day.
Posted Nov 11, 2025 - 09:05 PST

Update

We are continuing to work on a fix for this issue.
Posted Nov 10, 2025 - 13:54 PST

Update

We are continuing to review and work on impacted charges.
Posted Nov 10, 2025 - 10:11 PST

Update

A fix has been deployed. Our team is now working on cleanup of impacted charges.
Posted Nov 10, 2025 - 07:54 PST

Identified

The issue has been identified, and a fix is being implemented.
Posted Nov 09, 2025 - 11:32 PST

Investigating

We are currently investigating an issue impacting charge processing.
Posted Nov 09, 2025 - 10:06 PST
This incident affected: Recharge Platform (Recharge Charge Processing, Recharge Customer Portal, Recharge Merchant Portal).