Issues accessing Recharge admin links via Shopify

Incident Report for Recharge

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 20:04 PDT

Monitoring

We received reports of issues accessing the Recharge admin via Shopify and with saving changes in the customer portal. Our team has released a fix. We are seeing recovery and will continue monitoring.
Posted Mar 20, 2025 - 17:41 PDT
This incident affected: Recharge Customer Portal and Recharge Merchant Portal.